"Export Items" button does nothing after click

Highlighted
Six Stars

"Export Items" button does nothing after click

Hi All

 

I am using below talend version with JDK 1.8.0_121. 

Talend Version.PNG

 

I am unable to export talend items from studio. Export button doesn't do any after click. I can see below error in .log.

 

!MESSAGE Unhandled event loop exception

java.lang.IllegalArgumentException: Comparison method violates its general contract!

 

Any suggestion 

Thanks

Moderator

Re: "Export Items" button does nothing after click

Hello,

Are you using oracle JDK 1.8? Did you install serveral JDKs in your machine? Both JDK 1.7 and 1.8?

Please follow these steps;

Set the JAVA_HOME Environment variable:

Define your JAVA_HOME environment variable so that they point to the JDK installation directory.

Example: C:/Java/jdk1.8.0_121.

Add the previously defined JAVA_HOME variable to the Path environment variable.

Example: <PathVariable>;%JAVA_HOME%\bin.

Additionally, if setting the JAVA HOME fails add the following line in the .ini file (example: Talend-Studio-win-x86_64.ini) for studio:

-vm path to java bin

Example:

-vm C:\Program Files\Java\jdk1.8.0_121\bin

Let us know if it is OK with you.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: "Export Items" button does nothing after click

Hi Sabrina,

Are you using oracle JDK 1.8?  - Yes

Did you install serveral JDKs in your machine? Both JDK 1.7 and 1.8? 

- I am using both 5.6 and 6.3 talend so I have to keep  both 32bit 1.7 jdk and 64bit 1.8 jdk.
- Both JDK are in different folders
- For talend 5.6 I use .bat to open studio and for 6.3 using talend app exe.

- I am using window 7 64bit. 

 

Please follow these steps;

Set the JAVA_HOME Environment variable:

Define your JAVA_HOME environment variable so that they point to the JDK installation directory.

Example: C:/Java/jdk1.8.0_121.

Add the previously defined JAVA_HOME variable to the Path environment variable.

Example: <PathVariable>;%JAVA_HOME%\bin.

Additionally, if setting the JAVA HOME fails add the following line in the .ini file (example: Talend-Studio-win-x86_64.ini) for studio:

-vm path to java bin

Example:

-vm C:\Program Files\Java\jdk1.8.0_121\bin  - set this too.

Java_home.PNG

 

- Still it not working.

 

The issue is specific to the project. In other project export working fine.  Every one my team facing same issue with the project. 

 

Thanks 

Bhavik

 

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.