TimeOut Runtime Karaf

Five Stars

TimeOut Runtime Karaf

Hello,

 

I have a job calling a webservice using tESBConsumer.

My problem is how to change the timeout on karaf server after deploy the job?

 

I try to change the org.ops4j.pax.web.cfg file and set org.ops4j.pax.web.server.idleTimeout=100000 but I still have the timeout at 60 seconds.

 

Thanks for your reply.


Accepted Solutions
Moderator

Re: TimeOut Runtime Karaf

Hello,

Please have a look at this online document about:TalendHelpCenter:HTTP Conduit OSGi Configuration Parameters

On Runtime we use the 'standard' CXF-Conduit File to specific these parameters.

The specific parameter you look for are:
client.ConnectionTimeout
client.ReceiveTimeout

Let us know if it is Ok with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

All Replies
Moderator

Re: TimeOut Runtime Karaf

Hello,

Please have a look at this online document about:TalendHelpCenter:HTTP Conduit OSGi Configuration Parameters

On Runtime we use the 'standard' CXF-Conduit File to specific these parameters.

The specific parameter you look for are:
client.ConnectionTimeout
client.ReceiveTimeout

Let us know if it is Ok with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Three Stars

Re: TimeOut Runtime Karaf

This is the right configuration?

the timeout is consedered in seconds or milliseconds?

 

Thanks

 

#Common SSL conduit configuration

url = https://localhost.*

client.ConnectionTimeout = 120000
client.ReceiveTimeout = 120000

tlsClientParameters.disableCNCheck = true
tlsClientParameters.trustManagers.keyStore.type = JKS
tlsClientParameters.trustManagers.keyStore.password = password
tlsClientParameters.trustManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.keyManagers.keyStore.type = JKS
tlsClientParameters.keyManagers.keyStore.password = password
tlsClientParameters.keyManagers.keyStore.file = ./etc/keystores/keystore.jks
tlsClientParameters.keyManagers.keyPassword = password
tlsClientParameters.trustManagers.keyPassword = password

tlsClientParameters.cipherSuitesFilter.include = .*_EXPORT_.*,.*_EXPORT1024_.*,.*_WITH_DES_.*,.*_WITH_AES_.*,.*_WITH_NULL_.*,.*_DH_anon_.*

Five Stars

Re: TimeOut Runtime Karaf

Yes this is the right configuration. It works for me.

 

the timeout is consedered in milliseconds. For your example, it's 120000 milliseconds or 120 seconds.

Just specify your url for your example, you call a localhost url.