Four Stars

Talend Job Runs fine in Open Studio - but fails when trying to run from .bat

The error I get when trying to run it from .bat is:

 

java.lang.ClassNotFoundException: com.ibm.db2.jcc.DB2Driver
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at timeintegration.sf_to_mx_projects_0_1.SF_to_MX_Projects.tDB2Connection_1Process(SF_to_MX_Projects.java:1037)
at timeintegration.sf_to_mx_projects_0_1.SF_to_MX_Projects.tSalesforceConnection_1Process(SF_to_MX_Projects.java:956)
at timeintegration.sf_to_mx_projects_0_1.SF_to_MX_Projects.runJobInTOS(SF_to_MX_Projects.java:7198)
at timeintegration.sf_to_mx_projects_0_1.SF_to_MX_Projects.main(SF_to_MX_Projects.java:7004)

 

I do have the db2cc jars installed in Talend, and the job runs with ZERO errors within Open Studio itself. Any ideas?

 

UPDATE: I figured out it was trying to use a jar file called "db2cc4.jar", which was not the one included when I built the job. I'm not sure why that happened, but easy to fix. So, I don't need an answer anymore, but hope this helps someone!

  • Data Integration
1 ACCEPTED SOLUTION

Accepted Solutions
Employee

Re: Talend Job Runs fine in Open Studio - but fails when trying to run from .bat

Great Info.  Thanks.

2 REPLIES
Employee

Re: Talend Job Runs fine in Open Studio - but fails when trying to run from .bat

Great Info.  Thanks.

Moderator

Re: Talend Job Runs fine in Open Studio - but fails when trying to run from .bat

Hello,

Could you maybe set this thread as resolved to help other find it easily?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.