Four Stars

Service has already been deployed in the container?

I'm trying to deploy a new version of my services on TAC but when I go to deploy them it says they're already deployed in the container. I have deleted them from the ESB conductor before and I've gone on karaf and verified that they're gone from there as well. The deployment actually succeeds but when I check the bundle it lists previous versions of the service as active and newer versions as failure. What are the steps I need to take to completely remove the service from the system? So far I've done this: Undeploy/Stop/Delete the service from TAC, Stop the endpoint in karaf, Uninstall the bundles and bundle:refresh to verify they're gone.

  • Talend Administration Console
4 REPLIES
Nine Stars

Re: Service has already been deployed in the container?

are You also delete original (old) job file from deploy folder?

-----------
Four Stars

Re: Service has already been deployed in the container?

I don't believe so, where is the deploy folder located? How do I get to it?

Moderator

Re: Service has already been deployed in the container?

Hi,

On which build version you got this issue? Have you already created a case on talend support portal for your issue?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Service has already been deployed in the container?

We're on Talend Studio 6.2.1, we were able to deploy the correct versions after we removed the references to old versions in the feature:list and feature:repo-list.