Four Stars

Job works in studio but fails in command line

I have a job that uploads to a dataset in Salesforce Wave.  When I run the job interactively in TOS, it runs with no issues/errors.  When I run the generated batch file from a command prompt, I receive the following error:

 

Exception in thread "main" java.lang.NoClassDefFoundError: com/sforce/soap/partner/PartnerConnection
at wave.wavemain_2_14.WaveMain.tSalesforceWaveBulkExec_1Process(WaveMain.java:15017)
at wave.wavemain_2_14.WaveMain.tFileInputDelimited_2Process(WaveMain.java:12229)
at wave.wavemain_2_14.WaveMain.tFileCopy_1Process(WaveMain.java:31572)
at wave.wavemain_2_14.WaveMain.tWaitForFile_1Process(WaveMain.java:30100)
at wave.wavemain_2_14.WaveMain.runJobInTOS(WaveMain.java:31988)
at wave.wavemain_2_14.WaveMain.main(WaveMain.java:31675)
Caused by: java.lang.ClassNotFoundException: com.sforce.soap.partner.PartnerConnection
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 6 more

 

I've verified there is only one version of Java installed, and I'm calling a recent Salesforce API (34.0, also tried 37.0).  Other jobs seem to run fine without having to execute them from the designer.  Any ideas on what could be causing this?

  • Data Integration
2 REPLIES
Seven Stars TRF
Seven Stars

Re: Job works in studio but fails in command line

Hi,

Can you check the content of the "<jobname>/script/lib" folder?

You should find a "partnerBulk-xx.jar" file (xx depends of the version).

Open the file with WinRAR or something else to verify it contains "PartnerConnection.class".

Also tell us the version of Talend you are using.


TRF
Four Stars

Re: Job works in studio but fails in command line

I just checked and Under <jobname>/lib (no script folder) I have partner-37.0.3.jar (no PartnerBulk).  Exctracted that and under com/sforce/soap/partner I see PartnerConnection.class.  

 

This is in Talend Open Studio 6.3.1.

 

It looks like the .java files are missing though, when I compare my job to an old build from an older version of Talend (6.2.1, I believe).  Here is a listing of the files in both .jar's:

 

partner-37.0.3.jar

 

 PartnerConnection.class

 PartnerConnectionFactory.class

 PartnerConnectionWrapper.class

 

partner-34.0.0.jar

 PartnerConnection.class

 PartnerConnection.java

 PartnerConnectionFactory.class

 PartnerConnectionFactory.java

 PartnerConnectionWrapper.class

 PartnerConnectionWrapper.java