Five Stars

ImportItems is not working in commandline in deployment process- Talend

I'm new to Talend and trying to export & import a job using Command line. 

 

export process has completed and created the job.zip file at destination folder

 

but import is not happening.......import process got stuck once it logged on to project.......

 

Below command lines are used to do import:

----------------------------------------------------------------------

initRemote adminURL
listProject
logonProject -pn TargetProject -ul "userID" -up "password"
importItems "/destination/path/TESTJOB.zip" -o -s -sl
logoffProject

-------------------------------------------------------------------------

 

Logs:

-----------

!ENTRY org.talend.platform.logging 1 #Day and Timestamp#
!MESSAGE 2018-05-18 14:34:08,973 INFO org.talend.core.repository.model.ProxyRepositoryFactory - user, userlogged on TargertProject

COMPLETED at #Day and Timestamp#


!ENTRY org.talend.commandline #Day and Timestamp#
!MESSAGE logonProject

!ENTRY org.talend.commandline #Day and Timestamp#
!MESSAGE COMPLETED at Fri May 18 14:34:08 CDT 2018   ####### This is last line in log file and didn't write anything further.

1 ACCEPTED SOLUTION

Accepted Solutions
Five Stars

Re: ImportItems is not working in commandline in deployment process- Talend

Sabrina,

 

There was no error message in commandline log. But after multiple random attempts, job was deployed successfully. Also I'm running into different issue in import process in commandline.

 

Change I did: 

Removed the flag -sl (stats and Logs) from importItems command. 

 

Appreciate your response. Thanks.

2 REPLIES
Moderator

Re: ImportItems is not working in commandline in deployment process- Talend

Hello,

Is there any more error message in your commandline log?

You can find the log of Commandline in this path: <Talend Commandline install dir>/commandline-workspace/.metadata/.log

Note:Talend forbid import of items from an upper version.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: ImportItems is not working in commandline in deployment process- Talend

Sabrina,

 

There was no error message in commandline log. But after multiple random attempts, job was deployed successfully. Also I'm running into different issue in import process in commandline.

 

Change I did: 

Removed the flag -sl (stats and Logs) from importItems command. 

 

Appreciate your response. Thanks.