Four Stars

Continuous Integration & Remote CommandLIne

Hi, 

 

in Talend Dataservices 6.3.1, I try to use Jenkins to build & run my test in jobs but it's does'nt work, the build Source step failed

- Checkout : Works

- Donwload CI-Builder in Nexus : Works

-  Connect to CommandLIne : Works

- BuildSource in CommandLine : Works but generate nothing in .java directory

 

Image 949.png

 

 

[INFO] Starting to generate sources for the detected projects
[INFO] 
[INFO] Preparing for the project: PROJECT_CI
[INFO]  Logon project
[INFO]  Generating sources...
[INFO]  Logoff project
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 04:54 min
[INFO] Finished at: 2017-08-29T09:18:14+02:00
[INFO] Final Memory: 23M/1963M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.talend:ci.builder:6.3.1:generate (default-cli) on project buildsources: Execution default-cli of goal org.talend:ci.builder:6.3.1:generate failed.: NullPointerException -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.talend:ci.builder:6.3.1:generate (default-cli) on project buildsources: Execution default-cli of goal org.talend:ci.builder:6.3.1:generate failed.
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:154)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:146)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:117)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:81)
	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:309)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:194)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:107)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:993)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:345)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:191)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-cli of goal org.talend:ci.builder:6.3.1:generate failed.
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:145)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
	... 20 more
Caused by: java.lang.NullPointerException
	at org.talend.utils.io.FilesUtils.copyFolder(FilesUtils.java:120)
	at org.talend.jobbuilder.AbstractJobBuilder.copyResources(AbstractJobBuilder.java:170)
	at org.talend.jobbuilder.JobBuilder.executeCommandline(JobBuilder.java:145)
	at org.talend.jobbuilder.AbstractJobBuilder.execute(AbstractJobBuilder.java:92)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
	... 21 more
[ERROR] 

My BuildJb_pom.xml

 

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.talend</groupId>
<artifactId>buildsources</artifactId>
<version>6.3.1</version>
<packaging>pom</packaging>

<build>
    <plugins>
        <plugin>
            <groupId>org.talend</groupId>
            <artifactId>ci.builder</artifactId>
            <version>6.3.1</version>
            <executions>
                <execution>
                    <phase>generate-sources</phase>
                    <goals>
                        <!-- server mode -->
                        <goal>generate</goal>
                    </goals>
                    <configuration>
                    </configuration>
                </execution>
            </executions>
        </plugin>
    </plugins>
</build>

<pluginRepositories>
    <!-- everything through Maven Central Proxy -->
        <pluginRepository>
            <id>Central</id>
            <name>Central</name>
            <url>http://localhost:8081/nexus/service/local/repositories/central/content/</url>
        </pluginRepository>
        <pluginRepository>
            <id>thirdparty</id>
            <name>thirdparty</name>
            <url>http://localhost:8081/nexus/service/local/repositories/thirdparty/content/</url>
        </pluginRepository>
</pluginRepositories>

</project>

Do you have any idea why ?

  • Data Integration
  • Talend Commandline
1 ACCEPTED SOLUTION

Accepted Solutions
Four Stars

Re: Continuous Integration & Remote CommandLIne

I found the issue. My CommandLine was'nt run in the good workspace.

 

I started a dedicated CommandLine and it's worked now.

1 REPLY
Four Stars

Re: Continuous Integration & Remote CommandLIne

I found the issue. My CommandLine was'nt run in the good workspace.

 

I started a dedicated CommandLine and it's worked now.