Four Stars

6.4.1+ JRE1.8.0.+ Unable to Build Jobs

I am using Talend Open Studio 6.4.1.20170623_1246.  I have 9 jobs that I previously built without error and am running (jre1.8.0_144).   All jobs have Default set in Context.  

 

One of these jobs was allowing duplicate records.  I have modified and went to build but received an error (see below).  After working on it for some time I decided to build all of the other jobs using a different path to see what would happen.  Of the 9 only 3 built without error. I can't find a difference between them.  I have set the path in my Project settings but see nothing where my log files should be.  I have tried jre1.8.0_171 and jre1.8.0_181 as well with no change.

 

Any assistance would be appreciated.  

 

java.lang.Exception: Job was not built successfully, please check the logs for more details available on the workspace/.Java/lastGenerated.log
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJob(BuildJobManager.java:277)
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJob(BuildJobManager.java:164)
at org.talend.repository.ui.wizards.exportjob.scriptsmanager.BuildJobManager.buildJobs(BuildJobManager.java:108)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage.buildJobWithMaven(JobScriptsExportWizardPage.java:1487)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage$8.run(JobScriptsExportWizardPage.java:1389)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:466)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:374)
at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:1059)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizardPage.finish(JobScriptsExportWizardPage.java:1394)
at org.talend.repository.ui.wizards.exportjob.JavaJobScriptsExportWSWizardPage.finish(JavaJobScriptsExportWSWizardPage.java:1244)
at org.talend.repository.ui.wizards.exportjob.JobScriptsExportWizard.performFinish(JobScriptsExportWizard.java:126)
at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:853)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:438)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:619)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:832)
at org.eclipse.jface.window.Window.open(Window.java:808)
at org.talend.repository.ui.actions.ExportJobScriptAction.doRun(ExportJobScriptAction.java:117)
at org.talend.repository.ui.actions.AContextualAction$2.run(AContextualAction.java:632)
at org.talend.repository.RepositoryWorkUnit.executeRun(RepositoryWorkUnit.java:99)
at org.talend.core.repository.model.AbstractRepositoryFactory.executeRepositoryWorkUnit(AbstractRepositoryFactory.java:258)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.executeRepositoryWorkUnit(LocalRepositoryFactory.java:3369)
at org.talend.core.repository.model.ProxyRepositoryFactory.executeRepositoryWorkUnit(ProxyRepositoryFactory.java:2119)
at org.talend.repository.ui.actions.AContextualAction.run(AContextualAction.java:641)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:519)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:595)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:511)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:420)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.talend.rcp.intro.Application.start(Application.java:255)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

 

 

4 REPLIES
Moderator

Re: 6.4.1+ JRE1.8.0.+ Unable to Build Jobs

Hello,

For v6 of Talend products JDKv1.8 is required instead of JRE. You need to use JDK to develop the Java programs, and JRE to run the programs.

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: 6.4.1+ JRE1.8.0.+ Unable to Build Jobs

 

 Installed jdk1.8.0_181.  Same error on build.

talend1.pngtalend2.png

 

Four Stars

Re: 6.4.1+ JRE1.8.0.+ Unable to Build Jobs

Then I removed the jre's from the Preferences.... Still got the error.
Moderator

Re: 6.4.1+ JRE1.8.0.+ Unable to Build Jobs

Hello,

Could you please create a new project from within TOS 6.4.1 and manually copy over the pertinent (code, context, lib, metadata, process) folders from the old path to the new. Please make sure the talend.project file is not copied over. 
Try to start TOS 6.4.1 in the new path to see if you can now build your projects as standalone packages again?
Let us know if it is OK with you.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.