tMDMInput generate bugged message on version 5.3.0 r101800

One Star

tMDMInput generate bugged message on version 5.3.0 r101800

Hi, I tested the MDM 5.3.0 r101800 and I found some troubles using tMDMInput,
I created a job to read data from MDM database create dwith MDM 5.2.1.
- The job composed of tMDMInput and tLogRow
- I run the Job, the out put on console of tLogrow show error messages listed at the end of this POST.
- No message output on server side. It seems like the studio dosn't communicates with the server.
- I created the same job on MDM 5.2.1 It works verry well.

Any explaination about this message and is MDM 5.3.0 a non stable version ?????

MESSAGE OUTPUT ON tLogµRow CONSOL:
----------------------------------------
Démarrage du job taqua a 15:49 07/05/2013.
connecting to socket on port 3783
connected
15:49:25,688 DEBUG getBundle(org.apache.axis,org.apache.axis.i18n,resource,null,...)
15:49:25,696 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource, locale fr_FR
15:49:25,696 DEBUG Created org.apache.axis.i18n.resource, linked to parent null
15:49:25,696 DEBUG getBundle(org.apache.axis,org.apache.axis.utils,resource,null,...)
15:49:25,698 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.utils.resource, locale fr_FR
15:49:25,776 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource, locale fr_FR
15:49:25,776 DEBUG Root package not found, cross link to org.apache.axis.i18n.resource
15:49:25,776 DEBUG Root package not found, cross link to org.apache.axis.i18n.resource
15:49:25,776 DEBUG org.apache.axis.i18n.resource::handleGetObject(engineConfigLoadFactory)
15:49:25,877 DEBUG Factory org.apache.axis.configuration.EngineConfigurationFactoryServlet Ignored: unable to load/resolve class.
15:49:25,877 DEBUG org.apache.axis.i18n.resource::handleGetObject(engineFactory)
15:49:25,877 DEBUG Got EngineFactory: org.apache.axis.configuration.EngineConfigurationFactoryDefault
15:49:25,881 DEBUG Enter: AxisEngine::init
15:49:25,935 DEBUG org.apache.axis.i18n.resource::handleGetObject(attachEnabled)
15:49:25,976 DEBUG Attachment support is enabled? true
15:49:25,995 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory(class java.lang.String, {http://xml.apache.org/xml-soap}PlainText)
15:49:25,997 DEBUG org.apache.axis.i18n.resource::handleGetObject(oddDigits00)
15:49:25,997 DEBUG org.apache.axis.i18n.resource::handleGetObject(badChars01)
15:49:26,027 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory(class java.awt.Image, {http://xml.apache.org/xml-soap}Image)
15:49:26,077 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory(class javax.mail.internet.MimeMultipart, {http://xml.apache.org/xml-soap}Multipart)
15:49:26,078 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory(interface javax.xml.transform.Source, {http://xml.apache.org/xml-soap}Source)
15:49:26,080 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory(class org.apache.axis.attachments.OctetStream, {http://xml.apache.org/xml-soap}octet-stream)
15:49:26,176 DEBUG Enter/Exit: JAFDataHandlerDeserializerFactory()
15:49:26,206 DEBUG Exit: AxisEngine::init
15:49:26,239 DEBUG @914f6a added parameter >name: {urn-com-amalto-xtentis-webservice}WSGetComponentVersion
typeEntry: null
mode: IN
position: 0
isReturn: false
typeQName: {urn-com-amalto-xtentis-webservice}WSGetComponentVersion
javaType: class org.talend.mdm.webservice.WSGetComponentVersion
inHeader: false
outHeader: false
@1f4cbee<total parameters:1
15:49:26,276 DEBUG @914f6asetReturnType({urn-com-amalto-xtentis-webservice}WSVersion)
15:49:26,280 DEBUG @154864a added parameter >name: {urn-com-amalto-xtentis-webservice}WSPing
.
.
.
.
.
Very long error message!!!
Employee

Re: tMDMInput generate bugged message on version 5.3.0 r101800

Hi,
Thanks for testing your 5.2.1 jobs with 5.3.0 version. That's the first time I hear of an issue with 5.3.0's tMDMInput. Can you test the following:
#1 If you create the same job "from scratch", do you have the same issue? Or does it only happen when you import for 5.2.1 job to a 5.3.0 workspace?
#2 The error message seems to be more a log4j output configured in DEBUG level (hence the amount of text written to console). Do you have any exception in the log? Did you configure anything to change logger's default level?
#3 Does tMDMInput returns record(s)? Can you post parameters of the tMDMInput component?
Thanks.
One Star

Re: tMDMInput generate bugged message on version 5.3.0 r101800

Hello fhuaulme
I tested point #1 of your post, I'v had the same message ( see at the end of this post) when the debugging was finished the tMDMInput returns records.
You say in #2 the log4j output configured in DEBUG level, how can I desactivate it?

tMDMInput parameters are i standard mode:
URL : "http://localhost:8180/talend/TalendPort"
USER: "admin"
PASSWORD: "talend"
Entity: "refSpecific_Email"
Container: "FrozoneAdmin"
Thank you



Démarrage du job Check a 09:38 21/07/2013.
connecting to socket on port 3680
connected
09:38:52,302 DEBUG getBundle(org.apache.axis,org.apache.axis.i18n,resource,null,...)
09:38:52,319 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource, locale fr_FR
09:38:52,319 DEBUG Created org.apache.axis.i18n.resource, linked to parent null
09:38:52,321 DEBUG getBundle(org.apache.axis,org.apache.axis.utils,resource,null,...)
09:38:52,325 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.utils.resource, locale fr_FR
09:38:52,325 DEBUG loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource, locale fr_FR
09:38:52,326 DEBUG Root package not found, cross link to org.apache.axis.i18n.resource
09:38:52,326 DEBUG Root package not found, cross link to org.apache.axis.i18n.resource
09:38:52,326 DEBUG org.apache.axis.i18n.resource::handleGetObject(engineConfigLoadFactory)
09:38:52,327 DEBUG Factory org.apache.axis.configuration.EngineConfigurationFactoryServlet Ignored: unable to load/resolve class.
09:38:52,328 DEBUG org.apache.axis.i18n.resource::handleGetObject(engineFactory)
09:38:52,332 DEBUG Got EngineFactory:
One Star

Re: tMDMInput generate bugged message on version 5.3.0 r101800

Images of last post