One Star

[resolved] tFileCopy runs sucessfully, with Error tagged on it

Hello,
We are using TOS 5.5 for data integration.
I am trying for tFileCopy to work in my use case where a list of files with tFileList is to copied to different directory.
My job does the task and runs successfully with exit code = 0;.
But doing that, the tFileCopy component show an Error! tag as the job starts, even before 1st link from tFileList has started (may be compilation time). There is no issue with the purpose of file copy though, it places the files successfully and does the job. Even it kicks the next subjob on Component OK or SubJob ok link.
Please check on this as we need to get the job look successful if its successful.
Thanks,
Rahul
1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Hi,
Everything is working well except for "X" mark in tFileCopy? Could you please create a new job with new tfilecopy component to see if this issue repro?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
6 REPLIES
One Star

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

I think that if you use onSubJobOk rather than the componentOk to the tFileCopy then you should not have an error. The tFileCopy is trying to copy before the tFileOutputDelimited is done being written to.
Moderator

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Hi,
Everything is working well except for "X" mark in tFileCopy? Could you please create a new job with new tfilecopy component to see if this issue repro?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Thanks Sabrina. It worked well without the Error symbol when copied to a new job.
Moderator

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Hi RahulVerma,
Glad it is fixed. Could you please mark this topic as resolved?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Hi Sabrina,
I see below the 1st statement in the topic as "In fact, this topic is not resolved".
Not sure where to change the status one the forum.
Let me know the process, so I can do it next time going forward.
Thanks,
Rahul Verma
Moderator

Re: [resolved] tFileCopy runs sucessfully, with Error tagged on it

Hi,
This topic has been already marked as "Resolved" (see topic title). That's the reason why you see the 1st statement in the initial topic as "In fact, this topic is not resolved".
There are two modes for topic: "Set this topic as resolved" or "In fact, this topic is not resolved".
Thanks for your attention.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.