[resolved] Error in TOS launching

Highlighted
One Star

[resolved] Error in TOS launching

Hi, 
when i try to launch my TOS on a specific branch, i have an "java.lang.NullPointerException" error 
java.lang.NullPointerException
at org.talend.repository.localprovider.model.LocalRepositoryFactory.getSerializableFromFolder(LocalRepositoryFactory.java:601)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.getAll(LocalRepositoryFactory.java:509)
at org.talend.repository.remoteprovider.RemoteRepositoryFactory.getAll(RemoteRepositoryFactory.java:405)
at org.talend.core.repository.model.ProxyRepositoryFactory.getAll(ProxyRepositoryFactory.java:942)
at org.talend.migrationtool.MigrationToolService$2.run(MigrationToolService.java:163)
at org.talend.repository.RepositoryWorkUnit.executeRun(RepositoryWorkUnit.java:84)
at org.talend.core.repository.model.AbstractRepositoryFactory.executeRepositoryWorkUnit(AbstractRepositoryFactory.java:217)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.executeRepositoryWorkUnit(LocalRepositoryFactory.java:2689)
at org.talend.repository.svnprovider.SvnRepositoryFactory.executeRepositoryWorkUnit(SvnRepositoryFactory.java:397)
at org.talend.repository.remoteprovider.RemoteRepositoryFactory.executeRepositoryWorkUnit(RemoteRepositoryFactory.java:565)
at org.talend.core.repository.model.ProxyRepositoryFactory.executeRepositoryWorkUnit(ProxyRepositoryFactory.java:1770)
at org.talend.migrationtool.MigrationToolService.executeProjectTasks(MigrationToolService.java:262)
at org.talend.repository.localprovider.model.LocalRepositoryFactory.executeMigrations(LocalRepositoryFactory.java:2765)
at org.talend.repository.svnprovider.SvnRepositoryFactory.executeMigrations(SvnRepositoryFactory.java:1089)
at org.talend.repository.remoteprovider.RemoteRepositoryFactory.executeMigrations(RemoteRepositoryFactory.java:925)
at org.talend.core.repository.model.ProxyRepositoryFactory.executeMigrations(ProxyRepositoryFactory.java:246)
at org.talend.core.repository.model.ProxyRepositoryFactory.logOnProject(ProxyRepositoryFactory.java:1622)
at org.talend.repository.ui.login.LoginDialog$1.run(LoginDialog.java:344)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

I am on the 5.0.3 version and yesterday, I could launch the TOS on the branch with no problem.
Does anyone already have this error ? Do you have any ideas ofr a solution ? 
Thanks

Accepted Solutions
Highlighted
One Star

Re: [resolved] Error in TOS launching

Hello,
I met the same problem and I solved it by this way :
- checkout out the working branch with Eclipse
- go the metadata folder in the branch
- watch for the last modified files
- delete the last modified files
- commit the deletion (under Eclipse)
- launch the TOS
and it was Ok.
Benoit Jacob

View solution in original post


All Replies
Highlighted
Community Manager

Re: [resolved] Error in TOS launching

Hi
5.0.3 was an rather old version, what's your JDK version? Can you please upload log messages which are located in <studio install dir>/workspace/.metadata/.log
Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Highlighted
One Star

Re: [resolved] Error in TOS launching

Thanks for your reply,
I know that 5.0.3 is an old version but for the moment, it's the version the client is using... 
The JDK version is the 1.7 
I put the log messages in the attachment.

.log_20160331-0241.log
Highlighted
Community Manager

Re: [resolved] Error in TOS launching

Hi pdenis
5.0.3 does not support JDK 1.7, 1.6 is recommended JDK version. I would suggest you to downgrade JDK version, if the problem still exists, follow the steps to resolve it:
1. Back up your local workspace.
2. Delete the workspace folder. 
3. Restart talend enterprise studio, it will check out the project from svn server to local workspace again. 
Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Highlighted
One Star

Re: [resolved] Error in TOS launching

Hello,
I met the same problem and I solved it by this way :
- checkout out the working branch with Eclipse
- go the metadata folder in the branch
- watch for the last modified files
- delete the last modified files
- commit the deletion (under Eclipse)
- launch the TOS
and it was Ok.
Benoit Jacob

View solution in original post

Highlighted
Moderator

Re: [resolved] Error in TOS launching

Hi Benoit Jacob,
Thanks for sharing your solution with us.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend

Blog

Downloads and Trials

Test drive Talend's enterprise products.

Downloads