Displaying MDM Error Message for every single search

Highlighted
Six Stars

Displaying MDM Error Message for every single search

Dear All,

 

We have successfully designed and deployed the MDM Model/Container since the launch of TOS-MDM-6.4.1.

However, since today for every single record selection on the WEB-UI, am getting this pop-up as error message: 

 

"Could not create storage 'XYZ' with data model 'XYZ'.; nested exception is:

com.amalto.core.util.XtentisException: Unable to single search :: java.lang.RuntimeException: Could not create storage 'XYZ' with data model 'XYZ'"

 

Please note:

1. Application still working as expected though without breaking.

2. I have my MODEL & CONTAINER have same labels

3. Re-started to see if any memory over-heads.

 

What is the cause and fix to this erratic behaviour?

Appreciate any quick suggestions or work-around to fix this.

 

Thanks in advance,

Jagadish.

Moderator

Re: Displaying MDM Error Message for every single search

Hello,

Is your MDM data Container valid? Any custom type in data model?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: Displaying MDM Error Message for every single search

Dear Sabrina,

 

How do I check if the container is valid or corrupted?

I can read from the data container as well as write back.

 

FYI,

I have re-started the MDM server and everything came back as normal (along with this error message) and application is still running without any issues.

 

I have checked the MDM server logs and I see this:

 

2017-09-07 15:27:30,408 INFO [com.amalto.core.server.StorageAdminImpl] Container 'RUS_SFE_POSITIONS' does not exist.
2017-09-07 15:27:32,255 INFO [com.amalto.core.storage.datasource.DataSourceFactory] Reading from datasource file at 'D:\Talend_MDM_641\conf\datasources.xml'.
2017-09-07 15:27:32,930 INFO [com.amalto.core.storage.datasource.DataSourceFactory] Reading from datasource file at 'D:\Talend_MDM_641\conf\datasources.xml'.
2017-09-07 15:27:32,992 ERROR [com.amalto.core.server.DefaultItem] Unable to single search: : java.lang.RuntimeException: Could not create storage 'RUS_SFE_POSITIONS' with data model 'RUS_SFE_POSITIONS'.
java.lang.RuntimeException: Could not create storage 'RUS_SFE_POSITIONS' with data model 'RUS_SFE_POSITIONS'.
at com.amalto.core.server.StorageAdminImpl.create(Unknown Source)
at com.amalto.core.server.StorageAdminImpl.get(Unknown Source)
at com.amalto.core.server.DefaultItem.count(Unknown Source)

.

.

.

<ABOVE MESSAGE REPEATS>

 

Why is it saying container does not exists while my application is still running perfectly fine.

 

Thanks,

Jagadish.

Six Stars

Re: Displaying MDM Error Message for every single search

Dear All,

 

I tried to see what is the root cause of this error and below are my observations:

 

ATTEMPT#1:

1. Re-created entire project in a different server while replicating the existing model/container/entity_schemata.

2. Imported data into the Entity from Web-Console - Done successfully.

3. Web-Console is not showing the error message & Application is running fine.

 

ATTEMPT#2:

1. Updating the Entity from TOS-MDM custom job explicitly, I have checked/enabled the option "Add task id" (with value = "TOS_DI_641_SERVER") - Done successfully.

3. Web-Console SHOWS ERROR MESSAGE but Application is running fine.

 

Please let me know if this is a bug in the product.

 

Thanks in advance,

Jagadish.

Moderator

Re: Displaying MDM Error Message for every single search

Hello,

Is it a random issue for you? Could you please give us more steps to repro your issue? Does this issue occuer when you select single search on WEB UI?

Best regards

Sabrina

 

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Six Stars

Re: Displaying MDM Error Message for every single search

Dear Sabrina,

 

I have attached the images for you to reproduce the issue.

 

What I have done?

1. TOS-MDM - Load data into ENTITY/CONTAINER without enabling "Add task id" option - CLEAN

2. TOS-MDM - Load data into ENTITY/CONTAINER by enabling "Add task id" option with value "TOS-MDM-641-ETL" - CORRUPTED

 

Please advise.

 

Thanks in advance,

Jagadish.

Six Stars

Re: Displaying MDM Error Message for every single search

Dear Sabrina,

 

Let me know if you could re-produce the issue with the images attached above.

Please let me know what would be the Cause & Fix for this issue.

 

Thanks,

Jagadish.

Six Stars

Re: Displaying MDM Error Message for every single search

Hello,

 

Do you have news about this issue ? I have the same problem, adding a Task Id corrupt the data inserted.

 

Thanks.

Six Stars

Re: Displaying MDM Error Message for every single search

Hi,

 

I have not heard from anyone further on this issue.

However, as a work-around, we have excluded this option in the loading jobs and instead using custom flag in the entity.

 

Thanks,

Jagadish.

Cloud Free Trial

Try Talend Cloud free for 30 days.

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.