Four Stars


i'm trying to load xlsx file into postgresql database. my excel file contiens 11262 row but after excuting the job i find 14**** row and i don't know why i want only to find my 11262 row in my table


Re: Data_integration


Have you tried to use "Rejects" row from your tpostgresqlOutput component to see if there exists rejected rows?

Please uncheck "Use Batch Size" option in Advanced Settings of your tpostgresqlOutput component.

Best regards


Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Four Stars

Re: Data_integration

check your excel file there is probably approx 2,000 rows that have a space or similar in one of the columns hence the additional rows in the talend job. I'd just select 3,000 rows after the last populated row and delete them in the spreadsheet