Data Export from Database to MS-Excel

Eight Stars

Data Export from Database to MS-Excel

I would like to pull the data from database and export it to MS-Excel. Is it possible in Talend?

Moderator

Re: Data Export from Database to MS-Excel

Hello,

Are you using talend open studio for data quality product?

The ETL and ELT support feature is not available in talend open studio for data quality.

Please refer to this page about: https://www.talend.com/products/data-integration/data-integration-compare-all/

If you are using talend open studio for data integration, t<DB>Input-->tFileOutputExcel will meet your needs.

Let us know if it is OK with you.

 

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Eight Stars

Re: Data Export from Database to MS-Excel

Thank you very much.... This helps
Eight Stars

Re: Data Export from Database to MS-Excel

Thanks for helping me on getting the component name.

 

IMPORTANT

 

I am getting the below error while installing. Please help. Can you webex me and resolve it? i need this very badly.

 

 

 

!SESSION 2018-05-04 19:56:55.681 -----------------------------------------------
eclipse.buildId=unknown
java.version=10.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2018-05-04 19:56:58.814
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [334]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2018-05-04 19:56:58.822
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [336]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.common.ui.runtime 4 0 2018-05-04 19:56:58.829
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.common.ui.runtime [488]
Unresolved requirement: Import-Package: org.eclipse.swt.custom
-> Export-Package: org.eclipse.swt.custom; bundle-symbolic-name="org.eclipse.swt.gtk.linux.x86_64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
org.eclipse.swt.gtk.linux.x86_64 [423]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"
Unresolved requirement: Import-Package: org.eclipse.swt.events
-> Export-Package: org.eclipse.swt.events; bundle-symbolic-name="org.eclipse.swt.gtk.linux.ppc64le"; bundle-version="3.103.1.v20140903-1936"; version="0.0.0"
org.eclipse.swt.gtk.linux.ppc64le [413]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"
Unresolved requirement: Require-Bundle: org.talend.commons.runtime
-> Bundle-SymbolicName: org.talend.commons.runtime; bundle-version="7.0.1.20180411_1414"; singleton:="true"
org.talend.commons.runtime [490]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: org.eclipse.swt.widgets
-> Export-Package: org.eclipse.swt.widgets; bundle-symbolic-name="org.eclipse.swt.gtk.linux.s390"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
org.eclipse.swt.gtk.linux.s390 [419]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390))"
Unresolved requirement: Import-Package: org.eclipse.swt.graphics
-> Export-Package: org.eclipse.swt.graphics; bundle-symbolic-name="org.eclipse.swt.gtk.aix.ppc"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
org.eclipse.swt.gtk.aix.ppc [407]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc))"
Unresolved requirement: Import-Package: org.eclipse.swt
-> Export-Package: org.eclipse.swt; bundle-symbolic-name="org.eclipse.swt.gtk.aix.ppc64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
org.eclipse.swt.gtk.aix.ppc64 [406]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc64))"
Unresolved requirement: Import-Package: org.eclipse.swt.layout
-> Export-Package: org.eclipse.swt.layout; bundle-symbolic-name="org.eclipse.swt.gtk.hpux.ia64"; bundle-version="3.103.1.v20140903-1947"; version="0.0.0"
org.eclipse.swt.gtk.hpux.ia64 [409]
Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=hpux) (osgi.arch=ia64))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)