unable to add third party modules to Talend Data Quality

One Star

unable to add third party modules to Talend Data Quality

I can't download and install some of the necessary third party modules. I'd like to find out which urls the Studio is trying to use to download the modules.
I've searched this forum and I've read the help documentation "Identify required external modules" without finding an answer.
More Detail:
I'm using a direct connection to the internet - no proxy. I'm on OSX with Talend Data Quality 6.2.1.
When the module update window appears, the action column is empty and the "download and install all modules available" button is greyed out and unclickable.
I've tried going to Window > Show View > Talend >Modules. 
This view shows that the plugin.org.talend.libraries.mdm modules are "Not Installed" and then a number of third party modules are also listed as "Not Installed" including ORACLE, SAS, VERTICA, IBM, and REDSHIFT.
I've looked at the error log (Window > Show View > General > Error Log) which says the same for each module:

!MESSAGE 2016-09-26 11:19:00,465 INFO  org.talend.commons.exception.CommonExceptionHandler  - The download URL for RedshiftJDBC41- is not available

The obvious next step would be to try manually downloading the modules - but I can't see anywhere that tells me what URL the Studio is trying to use. 
Can anyone help with working out what the urls are for third party modules?


Re: unable to add third party modules to Talend Data Quality

Could you please take a look at online document about:TalendHelpCenter:Install external modules?
Best regards
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: unable to add third party modules to Talend Data Quality

Thanks for that Sabrina. I had read the documentation for OS X before - but the Windows docs make it clearer that you are using a Nexus repository.
I've tried making a manual connection to the Nexus repo  - but it needs a username and password?
--2016-09-27 09:34:44--  
Resolving talend-update.talend.com...
Connecting to talend-update.talend.com||:443... connected.
HTTP request sent, awaiting response... 401 Unauthorized
Username/Password Authentication Failed.

EDIT: The forum is deleting urls for some reason. I am connecting wget to https wget talend-update.talend.com at the path /nexus/service/local/repositories/releases/index_content
One Star

Re: unable to add third party modules to Talend Data Quality

OK - partially resolved the issue.
I had a nexus repository server running on localhost. It seems that Talend Studio Data Quality also runs an internal nexus repository instance? I stopped my local nexus server and more (but not all) of the third part modules downloaded.
I'm still having trouble getting the particular module I need right now though.
In the modules view it says:
Status:Not Installed
Module: RedshiftJDBC41-
If you go to h t t p s://talend-update.talend.com/nexus/#nexus-search;classname~REDSHIFT you can see that the Talend Nexus repo has

So I don't see why its not installing it.
I tried manually adding the latest version of the JDBC driver downloaded from Amazon and I can see it in my local DQ installation directory:
/Users/michaele_4321/Downloads/TOS_DQ-20160704_1411-V6.2-2.1/configuration/.m2/repository/org/talend/libraries/RedshiftJDBC41- with a pom that says
<project xmlns="" xmlns:xsi="" xsi:schemaLocation=" ">

Why is DQ complaining about wanting an older version of the module?
One Star

Re: unable to add third party modules to Talend Data Quality

I manually downloaded the RedshiftJDBC41- file from the Talend nexus repo and then used the "import external jars" option to load it into DQ - and it worked after restarting DQ.
I think it would be a good idea for someone at Talend to check why DQ was not automatically downloading the file - but I'm going to consider this issue resolved.

TL;DR  - Problem 1. A local Nexus repository can interfere with downloading third party modules. Problem 2 - some modules might need to be manually downloaded from the Talend Nexus repository at h t t p s://talend-update.talend.com/nexus and then imported to DQ using the "import external jars" option (the button that looks like a jar)

What’s New for Talend Spring ’19

Watch the recorded webinar!

Watch Now

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.



Introduction to Talend Open Studio for Data Integration.


Downloads and Trials

Test drive Talend's enterprise products.