One Star

[resolved] Problem Importing CSV with entries with Inverted commas

Hello,
I'm trying to setup a metadata connection for a CSV file. The CSV file uses a comma as a delimiter but the problem is that it has entries which are surrounded by inverted commas e.g.
12312,football, "Smith, Fred", striker
So the problem I get is that "Smith, Fred" gets imported as "Smith in one column and Fred" in the other.
Is there anyway for DQ to ignore the comma if enclosed between inverted commas and just import the whole thing into one column?
Otherwise I guess I can do some processing on the file myself before attempting to import it.
I'm using the following version:
"Talend Open Studio for Data Quality"
Version: 5.3.1
Build id: r104014-20130618-0403
Thanks.
1 ACCEPTED SOLUTION

Accepted Solutions
One Star

Re: [resolved] Problem Importing CSV with entries with Inverted commas

I've just managed to solve this and am kicking myself as I thought I had tried the options.
I got around this by setting the "Escape Char Settings" as following:
1. Select CSV
2. Set Text Enclosure to: "\""
This solution was also in http://www.talendforge.org/forum/viewtopic.php?id=1423 which I only found now as well.
2 REPLIES
One Star

Re: [resolved] Problem Importing CSV with entries with Inverted commas

I've just managed to solve this and am kicking myself as I thought I had tried the options.
I got around this by setting the "Escape Char Settings" as following:
1. Select CSV
2. Set Text Enclosure to: "\""
This solution was also in http://www.talendforge.org/forum/viewtopic.php?id=1423 which I only found now as well.
Employee

Re: [resolved] Problem Importing CSV with entries with Inverted commas

Glad to see that you found the solution.