One Star

Unable to successully install Open Studio for Data Quality - LINUX

Only able to run one of the linux versions of Talend Open studio for Data Quality - TOS_DQ-linux-gtk-x86_64. Howvere gives error message - see attached log file.
Am I using the correct version. What is wrong with the linux install ?
.log_20160525-0728.log
!SESSION 2016-05-25 08:42:13.163 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_91
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_GB
Command-line arguments:  -os linux -ws gtk -arch x86_64
!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2016-05-25 08:42:14.476
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.jdt.launching.macosx 4 0 2016-05-25 08:42:14.481
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"
    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.eclipse.compare.win32 4 0 2016-05-25 08:42:14.503
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare.win32
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=win32)"
    at org.eclipse.osgi.container.Module.start(Module.java:434)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
!ENTRY org.talend.platform.logging 1 0 2016-05-25 08:42:15.683
!MESSAGE 2016-05-25 08:42:15,679 INFO  org.talend.dataprofiler.rcp.Activator  - Starting Talend Profiling platform.

!ENTRY org.eclipse.osgi 4 0 2016-05-25 08:42:16.004
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: No more handles
    at org.eclipse.swt.SWT.error(SWT.java:4467)
    at org.eclipse.swt.browser.Mozilla.initMozilla(Mozilla.java:2067)
    at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:685)
    at org.eclipse.swt.browser.Browser.<init>(Browser.java:99)
    at org.talend.registration.wizards.register.TalendForgeDialog.createDialogArea(TalendForgeDialog.java:102)
    at org.talend.registration.wizards.register.TalendForgeDialog.createContents(TalendForgeDialog.java:95)
    at org.eclipse.jface.window.Window.create(Window.java:435)
    at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1101)
    at org.eclipse.jface.window.Window.open(Window.java:797)
    at org.talend.dataprofiler.rcp.intro.Application.openLicenseAndRegister(Application.java:112)
    at org.talend.dataprofiler.rcp.intro.Application.start(Application.java:60)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:498)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
2 REPLIES
Seventeen Stars

Re: Unable to successully install Open Studio for Data Quality - LINUX

Unfortunately most of the messages are crap and does not mean anything for you. I would say the studio is up and running on your system. The only thing is, you have to install the xulrunner. This package is needed for some parts of the studio using a browser based GUI - here the mozilla xul language. 
See some results from the help web site from Talend:
https://help.talend.com/pages/viewpage.action?pageId=265102477
One Star

Re: Unable to successully install Open Studio for Data Quality - LINUX

Missing packages installed and works on linux box