Standalone report jobs

I am using TDQ 4.1.1
I am attempting to export a TDQ report to run standalone. My main objective is to allow this report to populate the Oracle reporting database with the results of the analysis' contained within it.
To attempt to solve this, Ive done the following:
I?ve designed a test analysis, created a report, and verified that when this report is run in my client, the DB is updated.
I then right-click the report go to ?Generate Jobs?->?Launch a report?
This generates a talend job with a single component (tLaunchTDQReports).
On the server, I?ve installed the TDQ client and have pointed the tLaunchTDQReports component at this. I?ve also copied the ?report file? with the stupid machine-readable file name to the server (which IS NOT included in the exported job).
I?ve placed it in the workspace that is being fed to the TDQ executable as it starts.
I have tried more than a couple of different configurations, including editing the component to allow configuration of the workspace path fed to the TDQ executable, and also to properly escape the path to the report file.
Everything I try gets met with the same error. below is the error I find in the .log inside my server's workspace.
Has anyone been sucessful in populating the reporting database with standalone jobs? if so, where do I put the "*.rep" files so they can be found by the job?

Thanks for any help you can provide,
Garrett

!ENTRY org.talend.libraries 1 0 2010-11-22 13:57:05.664
!MESSAGE 2010-11-22 13:57:05,662 INFO org.talend.datacleansing.core.ui.ReportRunnerApplication - Starting up Application

!ENTRY org.eclipse.osgi 4 0 2010-11-22 13:57:06.507
!MESSAGE Application error
!STACK 1
org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: org.eclipse.core.internal.resources.ResourceException: Resource '/JAVA_TESTBED/TDQ_Data\ Profiling/Reports/RkFDVF9RVU9UQQ==20101105042831_0.1.rep' does not exist.
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:315)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:397)
at org.talend.dq.writer.EMFSharedResources.getResource(Unknown Source)
at org.talend.dq.helper.resourcehelper.ResourceFileMap.getFileResource(Unknown Source)
at org.talend.dq.helper.resourcehelper.RepResourceFileHelper.readFromFile(Unknown Source)
at org.talend.dq.helper.resourcehelper.RepResourceFileHelper.findReport(Unknown Source)
at org.talend.dataprofiler.core.tdq.action.ReportDocGenerator.<init>(Unknown Source)
at org.talend.datacleansing.core.ui.ReportRunnerApplication.run(Unknown Source)
at org.talend.datacleansing.core.ui.ReportRunnerApplication.start(Unknown Source)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)
Caused by: org.eclipse.core.internal.resources.ResourceException: Resource '/JAVA_TESTBED/TDQ_Data\ Profiling/Reports/RkFDVF9RVU9UQQ==20101105042831_0.1.rep' does not exist.
at org.eclipse.core.internal.resources.Resource.checkExists(Resource.java:319)
at org.eclipse.core.internal.resources.Resource.checkAccessible(Resource.java:196)
at org.eclipse.core.internal.resources.File.getContents(File.java:286)
at org.eclipse.core.internal.resources.File.getContents(File.java:277)
at org.eclipse.emf.ecore.resource.impl.PlatformResourceURIHandlerImpl$WorkbenchHelper.createPlatformResourceInputStream(PlatformResourceURIHandlerImpl.java:204)
at org.eclipse.emf.ecore.resource.impl.PlatformResourceURIHandlerImpl.createInputStream(PlatformResourceURIHandlerImpl.java:448)
at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:301)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1254)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:255)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:270)
... 21 more
4 REPLIES
Employee

Re: Standalone report jobs

Hi Garrett,
the procedure to execute the reports should be as follows:
1. create a job that executes the report in your TDQ studio (in a svn remote project)
2. install a TDQ studio on a server where the jobserver is running
3. connect this studio to the same project and retrieve the analyses and reports you have created (the commandline client may be used here)
4. close this studio
5. in TAC deploy and run the job that should launch the report.

There is no need to copy the report files, they must be retrieve from the remote project.
Let me know if this works.

Re: Standalone report jobs

Thanks for your time Scorreia--
In production, we will not have a TAC or SVN repository running. All our jobs are launched by an external scheduler -- maybe you can help me understand what will be possible-- and what will not.
Is it possible to use tLaunchDQReports (I only care about populating the reporting DB, we will use Microstrategy to generate reporting ) without a TAC or SVN repository? If so, how do I set up the exported jobs to do this?
Thanks!
Employee

Re: Standalone report jobs

Hi Garrett,
the other possibility is to export the TDQ items from your development studio and to import them in the production studio.
In order to do this, switch to the data profiler perspective and export the items with the export button. Then use the import button in the production studio to import them.
Then you also need to export and import the jobs with the tLaunchDQReports components (you need to do it from the Design workspace perspective).
Then, you may need to adapt the path of the executable manually in the tLaunchDQReport if your production OS is different from the development OS.
Another possibility, if you use your own scheduler, is to "export report script" with a right-click on the report item. This way, you don't use the tLaucnhDQReport component and you can schedule a .bat or .sh script file. This script file still needs the studio with the DQ items to be accessible locally.

Re: Standalone report jobs

Thanks! I will give this a try.