No Trimming in Output

Four Stars

No Trimming in Output

Hi all,

 

I am new to telend and I just started working with it today.

Everything works fine so far and I could create my first usable outputs except for one thing

 

In the Preview section of the screen I can see my "desired" result like 

   ABC27.12.2006        28     1  628250  4561       327.12.2006       582       610 DEF GHI

You will notice that I have blanks in this output because the files I have to create must have the information at specific positions in the line. I did that using the fixed length option in tLogRow

 

In my output tFileOutputDelimited all blanks are removed and eveything is written directly behind eachother like

 

ABC27.12.20062816282504561327.12.2006582610DEFGHI

How can I make talend stop trimming my output-file.

I just need a "simple" text file as output.

I searched all afternoon but I can't find a solution :-\

I tried different outputs too but it didn't help.

 

Thank you very much in advance and best regards

Frank

Eight Stars

Re: No Trimming in Output

Hello,

With this limited amount of information... Have you tried to use tFileOutputRaw component?
If not. can you please paste here and example of the source data and screenshot of the job you are using?

Regards
Lojdr