Data Service with Talend Component Kit fails on runtime

Highlighted
Four Stars

Data Service with Talend Component Kit fails on runtime

Dear Community,

 

I am looking for information about using Data Services with Talend Component Kit. This is for the Talend Cloud Data Services platform deployed in hybrid mode with Remote engines deployed on Virtual Servers on Azure.

 

Data Service works correctly on developer machine. We are able to invoke the REST service using Postman. When we deploy Data Service to Talend Cloud and then onto Talend Runtime Engine, despite TMC says the Data Service is deployed and Running, we are getting this error on Talend Runtime engine when invoking by postman:

Error message on the java.lang.NullPointerException at org.talend.sdk.component.runtime.manager.ComponentManager.autoDiscoverPlugins(ComponentManager.java:735)

 

To simplify the things we created tutorial based talend Component kit following these steps: https://talend.github.io/component-runtime/main/1.1.16/tutorial-create-my-first-component.html

 

When we used this Talend Component kit on batch integration on runtime – it worked fine. But when the component is included into data Service, it fails.

We use latest version of talend Studio and talend runtime / remote engines. 

 

Have you experience such behaviour?

 

Thanks Kris

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now