[resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

Highlighted
One Star

[resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

We have the enterprise license for studio 5.5.1. Our TmatchGroup component has stopped working and is giving the following error when I try to run the job



I tried to remove workspace, reinstall Talend but nothing worked. I did see similar issue being mentioned but no resolution in the talendforge


I get an error when I click on the chart also


Any help will be appreciated Thanks!
Moderator

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

Hi jchakrab,


[color=#5b5b5d][font=Verdana, Helvetica, Arial, sans-serif]What's your JDK and OS version? Can you execute your other jobs successfully in your studio?[/font][/color]


Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

Hi Sabrina, Java version is 1.7.0_13OS - Windows 7 64 bitYes other jobs are still running fine. Thank youJay xdshi wrote:
Hi jchakrab,


[color=#5b5b5d][font=Verdana, Helvetica, Arial, sans-serif]What's your JDK and OS version? Can you execute your other jobs successfully in your studio?[/font][/color]


Best regards
Sabrina
One Star

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

Hi Sabrina,

Any clue (hint!! Smiley Happy) will be helpful. I am kind of out of idea on this one :rolleyes:

Thank you for your time

Jay
Employee

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

This error reminds me that something similar may happen when we import an older project. See https://help.talend.com/search/all?query=You+get+an+error+when+trying+to+run+imported+Jobs+with+tSta...
I suspect that the library has been overridden by an older version. 

Do you see errors when you go to the "code" tab of the job editor?


Do you have a jar file called "org.talend.dataquality.record.linkage.jar" in the <studio>/lib/java folder?
or in <studio>/workspace/.Java/lib/ folder?
or in <studio>/workspace/<project>/libs/ ?

If yes, I suggest to close the studio, delete all these jar files (keep a copy somewhere just in case). Then restart the studio.
The correct library should be automatically retrieved from the studio when you open the job and go in the "code" tab of the job editor.
One Star

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

This appeared to have worked. Thank you all for contributing
One Star

Re: [resolved] Error with tMatchGroup Component (org.talend.dataquality unresolved)

hello ,
so i have same probleme with the compnent tMatchgroupe ?
can you give me yhe soluion please ?
thaks .

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Enabling Data Governance

Learn how to enable Data Governance

Watch Now

The Definitive Guide to Government Data Quality

Take a peek at the definitive guide to Government Data Quality

Read