[resolved] Error REST Service in Talend Runtime

One Star

[resolved] Error REST Service in Talend Runtime

I am trying to test a REST webservice from the Talend Runtime.

When I deploy the demo rest service in Talend Runtime, I can see it is deployed.
But when I invoke http://localhost:8888/customers i get no response.

If I look at the services (http://localhost:8040/services) i get an error null pointer exception. See attachment

Is there something missing? If I run the service in the studio everything works ok, but not in the runtime.

Are there components missing?


Talend MDM cluster 5.1 with ESB
Windows Server 2003
One Star

Re: [resolved] Error REST Service in Talend Runtime

By default REST service deployed to default context (http://localhost:8040/services/).
In case of DemoREST after deploy sou can see it at http://localhost:8040/services/ like
Available RESTful services:Endpoint address: http://localhost:8040/services/customers
WADL : http://localhost:8040/services/customers?_wadl
You can perform request using browser:
http://localhost:8040/services/customers
http://localhost:8040/services/customers/1
etc.
One Star

Re: [resolved] Error REST Service in Talend Runtime

Thanks. That did the trick!
One Star

Re: [resolved] Error REST Service in Talend Runtime

NOvIAc <a href="">onytmrrlevxp</a>, eifbvhtohelx, [link=]gxshnkoprbsj[/link],

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Talend API Designer – Technical Overview

Take a look at this technical overview video of Talend API Designer

Watch Now

Getting Started with APIs

Find out how to get started with APIs

Read