Perl Module DBD::Oracle can't be loaded error

One Star

Perl Module DBD::Oracle can't be loaded error

From a prospect:

I can't connect to ORACLE to write although I can connect to read. I set up an ORACLE connection in the metadata. I can extract the ORACLE schema info using this connection. But when I drag the connection from the metadata into the diagram to get an output object I get an error message when I run the job telling me that the ORACLE driver can't be loaded because the file doesn't exist. But the driver does exist as is shown below. I doubt we could read the schema if it didn't.
If I look in the modules panel it tells me that DBD:Smiley Surprisedracle is not installed. I know this is not true for a couple of reasons:
o I can write programs using the Perl DBI interface that access ORACLE. Can't do that unless DBD:Smiley Surprisedracle is installed
o DBD/Oracle shows up in a directory listing where all the other installed Perl modules show up
o If I execute perl -MCPAN -e 'install DBD:Smiley Surprisedracle' the install script tells me that DBD:Smiley Surprisedracle is up to date

Any suggestions as to why Talend can't see the DBD:Smiley Surprisedracle module?
Here's the error message and a couple of UNIX commands showing that the file said not to exist actually does exist. Any suggestions?
install_driver(Oracle) failed: Can't load '/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/DBD/Oracle/' for module DBD:Smiley Surprisedracle: cannot open shared object file: No such file or directory at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/ line 230.
at (eval 12) line 3
Compilation failed in require at (eval 12) line 3.
Perhaps a required shared library or dll isn't installed where expected
at /home/DahlkCa/TOS-All-r22547-V3.0.4/workspace/.Perl/ line 449
70 > pwd
71 > ls Oracle.h dbdimp.h ocitrace.h

any ideas? Or troubleshooting tips?


Tags (1)

Re: Perl Module DBD::Oracle can't be loaded error

How did you install DBD:Smiley Surprisedracle module? Linux distribution package or CPAN install?
Is the Oracle client installed? can you execute "sqlplus"?
One Star

Re: Perl Module DBD::Oracle can't be loaded error

Thanks Pierrick!

Here's the response from the prospect on the issue:

Well, this morning I found out how to make the tool see DBD:Smiley Surprisedracle - and the answer is simply to run it from the command line.

If I browse to the tool location using the Fedora file browser and double_click the icon, the tool runs, and it sees all the modules I installed to support Open Studio, but it doesn't see DBD:Smiley Surprisedracle (which was installed long before I installed Open Studio). If I run it from the command line it sees everything.

So there is something flakey in the interaction between the Fedora file browser and Open Studio. I'm not particularly interested in trying to debug this problem - I'm just going to press on.

This is a repeatable phenomenon - I switched back and forth between the two methods of starting Open Studio a couple of times just to be sure.

I assume that they dont have the same environment settings, but not worth tracking this down. A workaround has been found.



Talend named a Leader.

Get your copy


Kickstart your first data integration and ETL projects.

Download now

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend


Downloads and Trials

Test drive Talend's enterprise products.