One Star

How to install/set tHash in TOS 2.4.0

Hello Talend,
Since there is no "show hidden components" checkbox available on Preferences - Talend - Designer, how can i install/activate the tHash (Perl version) in TOS 2.4.0.
With kind regards,
Richansolo
Tags (1)
5 REPLIES
Employee

Re: How to install/set tHash in TOS 2.4.0

We've changed the way components are shown/hidden in the palette with TOS 2.4. Now you have to click the "Project settings" button (in the top button bar), "palette settings" and choose the components you want to show in the palette.
Unfortunately, we've decided to always hide the tHash component (but not the tArray/tArrayIn). We have considered it was not "usable as such", so we may have been wrong. Can you tell us how you use the tHash? Can you create a bugtracker request so that tHash becomes visible again in the palette?
One Star

Re: How to install/set tHash in TOS 2.4.0

Plegall,
If the TArray & TArrayIn can handle "Key - Value"-pairs with fast Value retrieval/update/deletion upon Key-query -> than i will start using these. But if these arrays have to be looped instead of queried like hashes as aforementioned, than please inform how to get back the Thash.
With kind regards,
Richansolo
Employee

Re: How to install/set tHash in TOS 2.4.0

If the TArray & TArrayIn can handle "Key - Value"-pairs with fast Value retrieval/update/deletion upon Key-query

Of course they don't, arrays are not hashes :-)
please inform how to get back the Thash

Create a feature request in the bugtracker (so that everybody will have it in next TOS release)
The workaround is to remove:
TECHNICAL="true"

in plugins/org.talend.designer.components.localprovider_2.4.0.r14858/components/tHash/tHash_perl.xml
One Star

Re: How to install/set tHash in TOS 2.4.0

Hi Plegall,
since i have not requested a 'bugtracker' before....do i need a separate account for that, because with my user-account i seem not to be able to login into the bugtracker!
Employee

Re: How to install/set tHash in TOS 2.4.0

since i have not requested a 'bugtracker' before....do i need a separate account for that, because with my user-account i seem not to be able to login into the bugtracker!

unfortunately, bugtracker and forum do not share user accounts. You need another account.
Good news : ecosystem uses forum account, but you're not yet interested in publishing your component, are you?