Can't reject integer fields with null using tSchemaComplianceCheck

Highlighted
One Star

Can't reject integer fields with null using tSchemaComplianceCheck

I've been struggling with this.

I'm using TOS 4.0, I tried it on TOS 3.2 the same problem happened.
I have very simple job design which imports a simple one-field table using tAccessInput. I use tSchemaComplianceCheck to get rid of records with null value. I use two tLogRows. One is used to display the Main flow. Another is used to display the rejects. I got an "Null Pointer Exception" after I run the job. Same thing happened with Double data type. Would you please let me know why? Isn't this a very simple job?in
One Star

Re: Can't reject integer fields with null using tSchemaComplianceCheck

toanog,
I've had the same problem and it is very frustrating, but usually it's simply that I didn't uncheck the "Check all columns for shcema". Once you do that, you edit the different check for each column. See figure below:
One Star

Re: Can't reject integer fields with null using tSchemaComplianceCheck

With String fields, it works just fine, though. But with int or double or maybe date, it doesn't work.
Community Manager

Re: Can't reject integer fields with null using tSchemaComplianceCheck

Hello
The 'nullable' option should be checked on the schema.

Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Can't reject integer fields with null using tSchemaComplianceCheck

shong,

My intetion is to reject the records with "null" value in the TestID field. Is there any other way to do it?

In my example, the records with TestID = 1 and TestID = 3 should be displayed in tLogRow_1 and the record with TestID = 2 should be displayed in tLogRow_2. I don't know how to do it.

Thanks.
Community Manager

Re: Can't reject integer fields with null using tSchemaComplianceCheck

Hello toanong
the records with TestID = 1 and TestID = 3 should be displayed in tLogRow_1 and the record with TestID = 2 should be displayed in tLogRow_2

As I said in previous post, check the 'nullable' option on the schema, you will get the expected result.

Best regards

shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
One Star

Re: Can't reject integer fields with null using tSchemaComplianceCheck

I checked the "nullable" option and all three rows are displayed in tLogRow_1, no row goes to tLogRow_2. It makes sense because the row with the null value meets the criteria of the tSchemaComplianceCheck and it passes through.
One Star

Re: Can't reject integer fields with null using tSchemaComplianceCheck

Hi,
Have you a solution for this, i have the same problem ??

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

Have you checked out Talend’s 2019 Summer release yet?

Find out about Talend's 2019 Summer release

Blog

Talend Summer 2019 – What’s New?

Talend continues to revolutionize how businesses leverage speed and manage scale

Watch Now

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend

Blog