tSystem component shows error while running a job in TAC

Eight Stars
Eight Stars

tSystem component shows error while running a job in TAC

Hi All,

 

  Am using tSystem component in Talend job. it's working fine. while scheduling the same job in TAC, tSystem component shows error. I have installed TAC in windows environment and using Linux job server for TAC schedule.

I have mentioned error details below:

 [INFO ]: smartnet.z_tsystem_0_1.z_tsystem - TalendJob: 'z_tsystem' - Start.
[statistics] connecting to socket on port 10470
[statistics] connected
[INFO ]: smartnet.z_tsystem_0_1.z_tsystem - tSystem_1 - Setting the parameters.
[INFO ]: smartnet.z_tsystem_0_1.z_tsystem - tSystem_1 - Root directory: 'C:/Users/RAJ/Desktop/test'.
[FATAL]: smartnet.z_tsystem_0_1.z_tsystem - tSystem_1 Cannot run program "cmd" (in directory "C:/Users/RAJ/Desktop/test"): error=2, No such file or directory
java.io.IOException: Cannot run program "cmd" (in directory "C:/Users/RAJ/Desktop/test"): error=2, No such file or directory
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at java.lang.Runtime.exec(Runtime.java:620)
at java.lang.Runtime.exec(Runtime.java:450)
at smartnet.z_tsystem_0_1.z_tsystem.tSystem_1Process(z_tsystem.java:379)
at smartnet.z_tsystem_0_1.z_tsystem.runJobInTOS(z_tsystem.java:823)
at smartnet.z_tsystem_0_1.z_tsystem.main(z_tsystem.java:641)
Caused by: java.io.IOException: error=2, No such file or directory
at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
at java.lang.ProcessImpl.start(ProcessImpl.java:134)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
... 5 more
[statistics] disconnected
Exception in component tSystem_1 (z_tsystem)
java.io.IOException: Cannot run program "cmd" (in directory "C:/Users/RAJ/Desktop/test"): error=2, No such file or directory
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
at java.lang.Runtime.exec(Runtime.java:620)
at java.lang.Runtime.exec(Runtime.java:450)
at smartnet.z_tsystem_0_1.z_tsystem.tSystem_1Process(z_tsystem.java:379)
at smartnet.z_tsystem_0_1.z_tsystem.runJobInTOS(z_tsystem.java:823)
at smartnet.z_tsystem_0_1.z_tsystem.main(z_tsystem.java:641)
Caused by: java.io.IOException: error=2, No such file or directory
at java.lang.UNIXProcess.forkAndExec(Native Method)
at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
at java.lang.ProcessImpl.start(ProcessImpl.java:134)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
... 5 more

 

Thanks
RAJ
Highlighted
Forteen Stars

Re: tSystem component shows error while running a job in TAC

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

Migrate Data from one Database to another with one Job using the Dynamic Schema

Find out how to migrate from one database to another using the Dynamic schema

Blog

Talend Cloud Developer Series – Defining Metadata

This video focuses on different methods of adding metadata to a job in Talend Cloud

Watch Now

Talend Cloud Developer Series – Updating Context Variables

This video will show you how to add context parameters to a job in Talend Cloud

Watch Now