tAzureStorageDelete throwing error when we run from TAC, but it is running fine in Talend

Highlighted
Five Stars

tAzureStorageDelete throwing error when we run from TAC, but it is running fine in Talend

Hi,

 

We try to delete the Azure blob folder from talend using the tAzureStorageDelete component. 

 

But, the component throws the below error

 

java.util.NoSuchElementException: An error occurred while enumerating the result, check the original exception for details.
at com.microsoft.windowsazure.services.core.storage.utils.implementation.LazySegmentedIterator.hasNext(LazySegmentedIterator.java:113)
at jukebox.osrm_edl_blob_subjob_0_1.OSRM_EDL_BLOB_SUBJOB.tAzureStorageDelete_2Process(OSRM_EDL_BLOB_SUBJOB.java:3421)

...

aused by: com.microsoft.windowsazure.services.core.storage.StorageException: The value for one of the HTTP headers is not in the correct format.
at com.microsoft.windowsazure.services.core.storage.StorageException.translateException(StorageException.java:113)
at com.microsoft.windowsazure.services.core.storage.utils.implementation.StorageOperation.materializeException(StorageOperation.java:158)
at com.microsoft.windowsazure.services.core.storage.utils.implementation.ExecutionEngine.executeWithRetry(ExecutionEngine.java:142)
at com.microsoft.windowsazure.services.core.storage.utils.implementation.LazySegmentedIterator.hasNext(LazySegmentedIterator.java:109)
... 26 more

 

 

We thought it is failing because there is no folder to delete that is the reason it is failing. 

But, when we try to run the same job from talend it is working fine.

 

we are not sure about the com.microsoft.windowsazure.services.core.storage.StorageException: The value for one of the HTTP headers is not in the correct format.

 

We use the General purpose Azure blob storage account for this and the container has full access. So, it wouldnt be access issue.

Is anyone faced this issue before ?

 

Could anyone help to resolve this issue ?!

Moderator

Re: tAzureStorageDelete throwing error when we run from TAC, but it is running fine in Talend

Hi,

On which talend build version you got this issue? Are your studio and TAC on different servers? Would you mind post your whole job design screenshots into forum?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: tAzureStorageDelete throwing error when we run from TAC, but it is running fine in Talend

Hi All,

 

The issue has been resolved .The problem was the deployment team deployed the old components. Thats reason it is working fine when we run from talend and it did not work when we try from TAC.

 

Thanks for the reply.

 

Thanks,

Sakthi

Moderator

Re: tAzureStorageDelete throwing error when we run from TAC, but it is running fine in Talend

Hello,

Great this issue has been fixed. Thanks for your update.

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

How to deploy Talend Jobs as Docker images to Amazon, Azure and Google Cloud reg...

Learn how to deploy Talend Jobs as Docker images to Amazon, Azure and Google Cloud registries

Blog

How OTTO Utilizes Big Data to Deliver Personalized Experiences

Read about OTTO's experiences with Big Data and Personalized Experiences

Blog

Talend Integration with Databricks

Take a look at this video about Talend Integration with Databricks

Watch Now