One Star

Talend Triggers not running in a given Durations

Hi All,
Environments : -
Talend Enterprise Big Data 5.3.1 (r104014)
Java version:1.7
Platform:x86-64
Operating System:Windows 2008 R2 Server

I have created a seven jobs and the jobs are set to run once every 5 seconds. Sometimes the Trigger running correctly but sometime the triggers are running every three minutes or sometimes even more. Also i have tired to modify quartz .properties file, like changing the thread count to 50 and idleWaitTime 5000ms (maximum). But the Issue still exists to run in alternate timings. Also the job in tac shows (Waiting for Task to End) somtimes. Also added index for the below columns in the tables.
idx_idQuartzJob ON "taskexecutionhistory
idx_idQuartzJob_expectedTriggeringDate ON "taskexecutionhistory
idx_idQuartzJob_taskStartDate ON "taskexecutionhistory
idx_idRemoteJobExecution ON "taskexecutionhistory
But the issue for the job running still exists in the tac console. 
8 REPLIES
Moderator

Re: Talend Triggers not running in a given Durations

Hi,
Is there any error message in TAC log? Which is located in< ServersInstallationPath>\apache-tomcat-XXX\logs.?
Have you already reported a ticket on Talend Support Portal?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend Triggers not running in a given Durations

Hi sabrina,
Thanks for the reply. Yes i have raised a ticket before one week but still didn't get any response on the Ticket. (Raised by our team)
https://jira.talendforge.org/browse/TBD-2958 
I have checked the server log but there is no error regarding the trigger running. Also the job only hangs in "Waiting for task to end" for few minutes and again started to run with a same message in other jobs. 
Also i have checked tac\archiva\jobs folder sometime the file for the job run is created every 5 seconds other times it takes 3 minutes for each run(create file in archiva jobs folder). 
Thanks,
Vinoth
Moderator

Re: Talend Triggers not running in a given Durations

Hi,
Yes i have raised a ticket before one week but still didn't get any response on the Ticket. (Raised by our team)
https://jira.talendforge.org/browse/TBD-2958

This is Talend Bug Tracker portal.
You'd better report a ticket on Talend Support Potal(only for subscribed users) so that we can give you a remote assistance through support cycle with priority.
Please check the announcement forum about new support portal:https://www.talendforge.org/forum/viewtopic.php?id=47230
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend Triggers not running in a given Durations

Help
One Star

Re: Talend Triggers not running in a given Durations

Hi ,
Its only showing to get app. I don't have any experience with ticket rising. Can you provide an information of where and how to raise a ticket with the Talend support portal.Please see the attached screenshot.
Thanks,
Vinoth
Moderator

Re: Talend Triggers not running in a given Durations

Hi,
If you are able to login successfully but receive a message saying that there are no apps, please contact support.us@talend.com for assistance.
Sorry for the inconvenience.
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: Talend Triggers not running in a given Durations

ThanksSmiley Happy,Already send mail to suport.us@talend.com now waiting for reply. 
Moderator

Re: Talend Triggers not running in a given Durations

Hi cgvak,
Feel free to let us know if there is any further help we can give.
@roy
We have replied your tschemacompliance post https://www.talendforge.org/forum/viewtopic.php?id=47460. Could you please take a look at it?
Best regards
Sabrina
--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.