TAC SSO Error on Login Page

Five Stars

TAC SSO Error on Login Page

We have installed TAC 6.3 and I was able to login using the web app. I changed the SSO setting to 'true' under configuration and I get the following error: 'SSO prevent direct login by window,' and I'm not able to change the login credentials. I wasn't able to change any other SSO settings as we have not configured a service account for Talend. I have changed the configuration setting in the configuration.properties file (sso.field.useSSOLogin=false) and I changed the corresponding entry in the configuration table in the database to 'ENABLED=0' and VALUE='false.' I restarted the TAC services and I'm still getting the same error. Is there somewhere else to change SSO settings?

Moderator

Re: TAC SSO Error on Login Page

Hi,

Could you please take a look at this jira issue:https://jira.talendforge.org/browse/TMC-2?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: TAC SSO Error on Login Page

Hi Sabrina,

I looked at the jira issue and from what I understand, I should still be able to login by the enter key, correct? I saw on the screenshot in the jira issue that the login button was blue, but on my screen it is greyed-out.

I tried entering a username and password and clicking enter, but I'm still not able to login to TAC. Was there another fix mentioned in the jira issue?

Thanks,

Alex

Five Stars

Re: TAC SSO Error on Login Page

Nevermind, I forgot to commit my update statement on the database side! Sorry about that. I now get the normal login screen. 

15TH OCTOBER, COUNTY HALL, LONDON

Join us at the Community Lounge.

Register Now

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

The Forrester Wave: Strategic iPaaS and Hybrid Integration Platforms, Q1 2019

Find out how Forrester rate different iPaaS and Hybrid Integration Platforms

Read

6 Ways to Start Utilizing Machine Learning with Amazon We Services and Talend

Look at6 ways to start utilizing Machine Learning with Amazon We Services and Talend

Blog

Why Companies Move to the Cloud: 7 Success Stories

Learn how and why companies are moving to the Cloud

Read Now