Subflows are complete but job still running

Highlighted
Seven Stars

Subflows are complete but job still running

We have a job with 3 subjobs. According to the log all the subjobs are done but the job continues to run. It takes between under an hour to around 12 hours for the job to finish. From the log it look like that even though jobs are complete, Talend is taking many many hours to execute the send email step.

 

Here is the log for job - I have removed accountID, User, RemoteEngineID etc for security reasons.

 

INFO | 2018-09-23T23:18:24.010Z | org.apache.karaf.features.core:4.1.3 | Removing features: feature:5996ea01e4b095230f1f7d88/[7.8.0,7.8.0] 
INFO | 2018-09-23T23:18:24.008Z | org.talend.ipaas.rt.deployment-agent:2.1.0 | Undeploy feature 5996ea01e4b095230f1f7d88/7.8. 
INFO | 2018-09-23T23:18:23.860Z | tipaas-jobserver-client:2.1.0 | Caught java.net.SocketException closing connection. 
INFO | 2018-09-23T23:18:23.854Z | tipaas-jobserver-client:2.1.0 | TalendJob: 'MASTER_POS_BULK_LOAD' - Done. 
INFO | 2018-09-23T23:18:23.812Z | tipaas-jobserver-client:2.1.0 | tSendMail_3 - Connection to '50.22.940.101' has succeeded. 
INFO | 2018-09-23T23:18:23.810Z | tipaas-jobserver-client:2.1.0 | tSendMail_3 - Connection attempt to '50.22.940.101'. 
INFO | 2018-09-23T22:40:49.847Z | tipaas-jobserver-client:2.1.0 | tSendMail_1 - Connection to '50.22.940.101' has succeeded. 
INFO | 2018-09-23T22:40:49.841Z | tipaas-jobserver-client:2.1.0 | tSendMail_1 - Connection attempt to '50.22.940.101'. 
INFO | 2018-09-23T22:38:36.485Z | tipaas-jobserver-client:2.1.0 | tSendMail_2 - Connection to '50.22.940.101' has succeeded. 
INFO | 2018-09-23T22:38:36.466Z | tipaas-jobserver-client:2.1.0 | tSendMail_2 - Connection attempt to '50.22.940.101'. 
INFO | 2018-09-23T10:32:12.671Z | tipaas-jobserver-client:2.1.0 | tRunJob_2 - The child job 'BulkLoad_POS_G_L' is done. 
INFO | 2018-09-23T10:32:12.670Z | tipaas-jobserver-client:2.1.0 | tRunJob_2 - The child job 'BulkLoad_POS_G_L' starts on the version '0.1' with the context 'Default'. 
INFO | 2018-09-23T10:32:12.664Z | tipaas-jobserver-client:2.1.0 | tRunJob_3 - The child job 'BulkLoad_POS_BB_TABLE' is done. 
INFO | 2018-09-23T10:32:12.663Z | tipaas-jobserver-client:2.1.0 | tRunJob_3 - The child job 'BulkLoad_POS_BB_TABLE' starts on the version '0.1' with the context 'Default'. 
INFO | 2018-09-23T10:32:12.653Z | tipaas-jobserver-client:2.1.0 | tRunJob_1 - The child job 'BulkLoad_POS_A_F' is done. 
INFO | 2018-09-23T10:32:12.652Z | tipaas-jobserver-client:2.1.0 | tRunJob_1 - The child job 'BulkLoad_POS_A_F' starts on the version '0.1' with the context 'Default'. 
INFO | 2018-09-23T10:32:12.570Z | tipaas-jobserver-client:2.1.0 | TalendJob: 'MASTER_POS_BULK_LOAD' - Start. 
INFO | 2018-09-23T10:32:06.980Z | tipaas-jobserver-client:2.1.0 | Generated log4j configuration file: C:\RemoteEngine-21\data\tmp\5996ea01e4b095230f1f7d88_7.82096772466013922615_log4j.xml 
INFO | 2018-09-23T10:32:06.779Z | tipaas-jobserver-client:2.1.0 | Job 5996ea01e4b095230f1f7d88_7.8 deploy status is: RUNNING 
INFO | 2018-09-23T10:32:06.578Z | tipaas-jobserver-client:2.1.0 | Job 5996ea01e4b095230f1f7d88_7.8 deploy status is: RUNNING 
INFO | 2018-09-23T10:32:06.377Z | tipaas-jobserver-client:2.1.0 | Job 5996ea01e4b095230f1f7d88_7.8 deploy status is: RUNNING 
INFO | 2018-09-23T10:32:06.173Z | tipaas-jobserver-client:2.1.0 | Job 5996ea01e4b095230f1f7d88_7.8 deploy status is: RUNNING 
INFO | 2018-09-23T10:31:35.015Z | org.talend.ipaas.rt.deployment-agent:2.1.0 | Flow 5996ea01e4b095230f1f7d88/7.8 was started; MDC: {flowVersion=7.8, flowID=5996ea01e4b095230f1f7d88, accountID=, executionDestination=REMOTE_ENGINE, userId=, flowExecutionId=2175a0d7-5709-4820-864e-c53f93374cbf, remoteEngineId=, workspaceId=58cdce10e4b077150832ed1e}; containerVersion: 2.1.0_iPaaS-RT-Flow_75_maintenance/cloud-winter-2018

 

 Here is the snapshot of job history from Talend Cloud Integration:

mri_bulk_load.PNG

Moderator

Re: Subflows are complete but job still running

Hello,

Could you please let us know on which talend build version you got this issue? Is there any error message in log?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Seven Stars

Re: Subflows are complete but job still running

Looks like we are on version 6.5.1. I have attached a screenshot:

 

talend_version.PNG

Moderator

Re: Subflows are complete but job still running

Hello,

Could you please let us know if there is any error message in log?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

15TH OCTOBER, COUNTY HALL, LONDON

Join us at the Community Lounge.

Register Now

2019 GARNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

What’s New for Talend Summer ’19

Watch the recorded webinar!

Watch Now

How to deploy Talend Jobs as Docker images to Amazon, Azure and Google Cloud reg...

Learn how to deploy Talend Jobs as Docker images to Amazon, Azure and Google Cloud registries

Blog

Talend API Services Publish to Talend Cloud

Learn how to publish your API Services to Talend Cloud

Watch Now

Cloud Data Warehouse Trends for 2019

Find out aboutCloud Data Warehouse Trends for 2019

Read