SQLBuilder doesn't working...

Five Stars

SQLBuilder doesn't working...

Enviornment : 

 

OS : windows server 2008 R2 Standard x64,  windows 10 x64 pro,  centos 6.5 x64

 

java : jdk 1.8, 17

 

Talend Studio : 6.2 / 6.4

 

 

I tried to open the SQLbuilder, it doesn't running, no response.

 

Ironically. when i run the job...  it's fine.

  Select Query(2.HISTORY_LIB_odp_link) is success, also insert/update Query is ok, and exit code is Zero.

 

image.png

 

 but SQLbuilder is doesn't pop UP!!

 

I think suspicious is the include of modules.

because Talend doesn't download mssql-jdbc.jar automatically. and then i go to download Microsoft. 

and put the external jar...   

 

 

I also many of DBMS(more than 7).

Despite the same enviorment, same target DBMS,

sometime SQLbuilder is doesn't work..(auto installed module by talend)  

What should I check out?

 

 

+ Additional Questions!

 

If I have Many Job(maybe more then 20) Talend Open Studio is too slow(somtimes TOS is shutdown!),  

(env : i5, SSD, 8GB)

Especially When Click the metadata.. It seems to be the limite base on the eclipse, but what can i do?

 

Thank you!!!

 

 

 

 

 

 

Moderator

Re: SQLBuilder doesn't working...

Hello,

Is there any message in error log(Window-->show view-->General-->error log) when the SQLbuilder doesn't run and no response? Does this issue only repro on your tMSSqlXXX Component?

 

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
Five Stars

Re: SQLBuilder doesn't working...

Thank you, reply

 

i didn't know error log ..

 

 

SQL builder error is 

Message : Unhandled event loop exception

Exception Stack Trace : 

java.lang.IllegalArgumentException: Index out of bounds
at org.eclipse.swt.SWT.error(SWT.java:4422)
at org.eclipse.swt.SWT.error(SWT.java:4356)
at org.eclipse.swt.SWT.error(SWT.java:4327)
at org.eclipse.swt.widgets.Widget.error(Widget.java:476)
at org.eclipse.swt.widgets.Tree.getItem(Tree.java:3133)
at org.talend.sqlbuilder.ui.DBStructureComposite.openNewEditor(DBStructureComposite.java:174)
at org.talend.sqlbuilder.ui.SQLBuilderDialog.createDialogArea(SQLBuilderDialog.java:302)
at org.eclipse.jface.dialogs.Dialog.createContents(Dialog.java:768)
at org.eclipse.jface.window.Window.create(Window.java:435)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1101)
at org.eclipse.jface.window.Window.open(Window.java:797)
at org.talend.designer.core.ui.editor.properties.controllers.AbstractElementPropertySectionController.openSQLBuilder(AbstractElementPropertySectionController.java:2194)
at org.talend.designer.core.ui.editor.properties.controllers.SqlMemoController.createCommand(SqlMemoController.java:178)
at org.talend.designer.core.ui.editor.properties.controllers.SqlMemoController.access$0(SqlMemoController.java:133)
at org.talend.designer.core.ui.editor.properties.controllers.SqlMemoController$1.widgetSelected(SqlMemoController.java:125)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4353)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1061)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4172)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3761)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run(PartRenderingEngine.java:1151)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1032)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:148)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:579)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at org.talend.rcp.intro.Application.start(Application.java:248)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

 

 

yes, only MSsql Input component only occured.

 

I press "Guess Query".. but still didn't work.

 

Moderator

Re: SQLBuilder doesn't working...

Hi,

We cannot repro your issue on our end. What does your input query look like? Can you use SQL builder in a simple job? Such as, toracleinput-->tlogrow.

Did you also get some memory exception?

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.
One Star

Re: SQLBuilder doesn't working...

Hello,

Same issue for me : SQLBuilder doesn't working

with Windows 7 pro, TOS DI 6.4.1 (and older too) 32bits, java 1.7

 

Thanks

 

Moderator

Re: SQLBuilder doesn't working...

Hello,


lionux wrote:

Hello,

Same issue for me : SQLBuilder doesn't working

with Windows 7 pro, TOS DI 6.4.1 (and older too) 32bits, java 1.7

 

Thanks

 


Are you using 32 bit  window 7 pro? The current recommended version is Java 8. Please review the compatible versions of talend open studio 6.4

TalendHelpCenter:Java

Best regards

Sabrina

--
Don't forget to give kudos when a reply is helpful and click Accept the solution when you think you're good with it.

Tutorial

Introduction to Talend Open Studio for Data Integration.

Definitive Guide to Data Integration

Practical steps to developing your data integration strategy.

Definitive Guide to Data Quality

Create systems and workflow to manage clean data ingestion and data transformation.