Recovery Checkpoint Not connecting to Target Server

Highlighted
Five Stars

Recovery Checkpoint Not connecting to Target Server

Basically I have a simple job with a check point set up in it that I've deployed and have configured a job in the TAC to run.  When the job fails and triggers that check point I can see it in the recovery console but when I try to actually recover from the check point I get an error "Connection to server failed"

 

I can see on the job server in the TalendJobServersFiles\jobexecutions\logs a folder has been created for the job execution of the recory.  And in the logs on the job server i see this,

 

2020-01-17T11:51:37,819 | ERROR | MultiSocketServer_CommandServer_ConnectionPool_pool-15-thread-7 | emote.server.MultiSocketServer$3 323 | 308 - org.talend.remote.server - 7.2.1 | java.lang.NullPointerException
org.talend.remote.commons.exception.ClientServerException: java.lang.NullPointerException
at org.talend.remote.server.AbstractObjectServerSocket.readInputStream(AbstractObjectServerSocket.java:109) ~[308Smiley Surprisedrg.talend.remote.server:7.2.1]
at org.talend.remote.server.AbstractServerSocket.startReadInputStreamLoop(AbstractServerSocket.java:51) ~[308Smiley Surprisedrg.talend.remote.server:7.2.1]
at org.talend.remote.server.AbstractServerSocket.start(AbstractServerSocket.java:40) ~[308Smiley Surprisedrg.talend.remote.server:7.2.1]
at org.talend.remote.server.MultiSocketServer$3.run(MultiSocketServer.java:321) [308Smiley Surprisedrg.talend.remote.server:7.2.1]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
at java.lang.Thread.run(Thread.java:745) [?:?]
Caused by: java.lang.NullPointerException
at java.util.Hashtable.put(Hashtable.java:459) ~[?:?]
at org.talend.remote.jobserver.server.CommandServerSocket.createTempContextPath(CommandServerSocket.java:1276) ~[?:?]
at org.talend.remote.jobserver.server.CommandServerSocket.buildCommandLine(CommandServerSocket.java:1056) ~[?:?]
at org.talend.remote.jobserver.server.CommandServerSocket.runJob(CommandServerSocket.java:771) ~[?:?]
at org.talend.remote.jobserver.server.CommandServerSocket.processRequest(CommandServerSocket.java:312) ~[?:?]
at org.talend.remote.server.AbstractObjectServerSocket.processRequestInternal(AbstractObjectServerSocket.java:148) ~[?:?]
at org.talend.remote.server.AbstractObjectServerSocket.readInputStream(AbstractObjectServerSocket.java:88) ~[?:?]
... 6 more

 

Any idea what the problem is?  The job runs perfectly fine if I run it without trying to run it from the recovery point.

Community Manager

Re: Recovery Checkpoint Not connecting to Target Server

I think we need your job or more details to investigate the issue, can you please open a ticket to our support portal?

Regards
Shong
----------------------------------------------------------
Talend | Data Agility for Modern Business
Five Stars

Re: Recovery Checkpoint Not connecting to Target Server

Right now I'm just pocing check points so the job is super simple.  Basically just writing something out to console, reading a file and logging it.  To create the error I'm just renaming the file.  Here's a screen shot of the recovery console, I ran the job once with the file available that's the first run which finishes successfully, then I renamed the file ran it again which errors out, then I tried to recover from the check point and that's when I get the Connection to server failed error when trying to recover from the check point.  So i'm just wondering if there's something obvious wrong with it.

 

 

Error Recovery.JPG

2019 GARTNER MAGIC QUADRANT FOR DATA INTEGRATION TOOL

Talend named a Leader.

Get your copy

OPEN STUDIO FOR DATA INTEGRATION

Kickstart your first data integration and ETL projects.

Download now

The Forrester Wave: Strategic iPaaS and Hybrid Integration Platforms, Q1 2019

Find out how Forrester rate different iPaaS and Hybrid Integration Platforms

Read

Have you checked out Talend’s 2019 Summer release yet?

Find out about Talend's 2019 Summer release

Blog

Talend Summer 2019 – What’s New?

Talend continues to revolutionize how businesses leverage speed and manage scale

Watch Now