Nexus configuration for TAC

Five Stars

Nexus configuration for TAC

Hi Folks:

 

I installed TAC and Nexus separately on the same box. I can connect to nexus fine via URL and set up repositories etc., but when I try to configure/connect to Nexus in TAC, receive  "Artifacts repository is unreachable". Is there a step by step "configure nexus for TAC" out there? I need to understand how to properly set up nexus repos, groups and other obvious settings I may be missing,  and use them in TAC configuration for "Artifact Repository".  

 

windows server 2016

TAC 6.4.1 on tomcat

Nexus Repository Manager OSS 3.10.0.04 installed as service - can reach and configure via browser, but can't configure TAC to connect

This is a dev box, so all services are installed locally, and I am using localhost as the host name in all URI's

 

1: I have set up 4 repos:

talend-custom-libs hosted maven2 Snapshot Permissive, allow redeploy

talend-custom-libs-release hosted maven2 Release Permissive allow redeploy

talend-custom-libs-snapshot hosted maven2 Snapshot Permissive, allow redeploy

talend-updates hosted maven2 Release Permissive, allow redeploy

2: 1 group repo:

nexus maven2 - included for repos above as members

 

3: added 'tadmin' user/pass

4: set the nexus group url (well I've tried many different URL's here) in TAC config

 

pic attached for reference.

 

Thank you

 

 

 

 

 


Accepted Solutions
Four Stars

Re: Nexus configuration for TAC

Hi jmartin

 

I tryed the same as you but was not able to get it up and running with version 3 of Nexus.

After i got back to 2.14.7 it was a success. The problem is in the changed repo access address of Nexus. I searched a lot of TAC config files but found no config for this Nexus access address.

 

Best regards

 


All Replies
Seven Stars

Re: Nexus configuration for TAC

 Hi jmartin,

 

The default URL of Nexus repository is http://localhost:8081/nexus. But in screen shot you mentioned it as  http://localhost:8081/repository/nexus.

 

So could you please try with http://localhost:8081/nexus and following credentials.

 

Default credentials :

User Name : admin

Password   : Talend123

Thanks & Regards
A Ravi Kumar
Mobile Number : +91 852-762-1083
Email-id : a.ravikumar104@gmail.com
Skype Id : ammanannaravikumar
Four Stars

Re: Nexus configuration for TAC

Hi jmartin

 

I tryed the same as you but was not able to get it up and running with version 3 of Nexus.

After i got back to 2.14.7 it was a success. The problem is in the changed repo access address of Nexus. I searched a lot of TAC config files but found no config for this Nexus access address.

 

Best regards

 

Seven Stars

Re: Nexus configuration for TAC

Hello jmartin,

 

with my server/setup, using "localhost" in TAC Artefact Repository configuration does not work, too, but <hostname> does.

So, on the TAC configuration page for the Artefact Repository in the "Nexus url" field, please replace "localhost" with your hostname (or IP address).

 

Best regards,

 

Thomas

 

Five Stars

Re: Nexus configuration for TAC

Hi I tried this to no avail, but thanks you

Five Stars

Re: Nexus configuration for TAC

Thanks but this does not work with version 3 of Nexus

Five Stars

Re: Nexus configuration for TAC

Thank you - I rolled back to version 2.14.7 and all is well.

The only thing that is not working at this point is the User Libraries section in TAC (pic attached) - do I have to add those repo's as I did in version three first?

Five Stars

Re: Nexus configuration for TAC

the answer is yes, I did have to add repos as listed in the 1st question. all is working now.

Thanks folks!