One Star

Error on Drools - "value '1.7' is not a valid language level"

Hi All,
I am working on creating a Drools rule on TAC.
When I am trying to run the drools rule it was throwing exception
"Caused by: org.drools.RuntimeDroolsException: value '1.7' is not a valid language level at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.getDefaultLanguageLevel(JavaDialectConfiguration.java:161)
at org.drools.rule.builder.dialect.java.JavaDialectConfiguration.init(JavaDialectConfiguration.java:56)
at org.drools.compiler.PackageBuilderConfiguration.addDialect(PackageBuilderConfiguration.java:273)
... 63 more"
I tried with two options
one is reference by the link
https://help.talend.com/display/KB/Exception%3A+tRuleSurvivorship+generates+rules+failed+with+JDK+7/
Second is https://jira.talendforge.org/browse/TUP-477/
But it did not work for me.. Can anyone help me on this?

Thanks
Shilpa

  • Data Quality
  • Talend Administration Center
3 REPLIES
Moderator

Re: Error on Drools - "value '1.7' is not a valid language level"

Hi,
Due to you are using talend enterprise subscription version,
I would suggest you to connect to the Talend Support portal and log your request, so that we treat it with priority and our support team can investigate it further by remote assistance through the support cycle.
Best regards
Sabrina
One Star

Re: Error on Drools - "value '1.7' is not a valid language level"

Hi Silpadowpati,
you got the solution for the below issue you are facing .
Im also facing same issue with drools .
1.6 drools 5.1.1.&5.4.0 it is running fine ,but when i change java version to 1.7 im gettin "unable to load dialect & 1.7 not a valid language issue.
Please help ,if you have solution for the below .
regards, naresh
Moderator

Re: Error on Drools - "value '1.7' is not a valid language level"

Hi
Here is a response in your another topic http://www.talendforge.org/forum/viewtopic.php?id=36479. Could you please have a look at it?
Best regards
Sabrina