Six Stars

TAC - Nexus, Artifacts repository is unreachable

This looks like a blocker for me.

 

In the TAC configuration, it doesn't seem to be able to reach the Artifacts repository. I can get to Nexus via the public DNS but I can't login using the Admin account and the password that I set in the cloudformation script. 

 

I switched the internal DNS address to the public DNS and it went from red to green but I'm not sure if it's configured correctly. 

 

I'm trying to get past section 6.4 in the User Guide (Run the Job from TAC). When I get to step 3, Click the Nexus button it just hangs (loading, spinning icon). 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Six Stars

Re: TAC - Nexus, Artifacts repository is unreachable

Edward and I worked out that the password I was using had an issue.

I changed ti2ETnxVvrGm! to admin123 and the issue cleared up. Obviously admin123 shouldn't be used in production. We didn't find a clear answer as to what Nexus password needs to include/exclude. 

 

 

3 REPLIES
Employee

Re: TAC - Nexus, Artifacts repository is unreachable

Hi Dustin

 

It sounds like you have two issues.  First, you cannot connect to your Nexus instance from your browser.  Second, the TAC Job  Conductor is having difficulty connecting when you try to create a new Job.

 

I have attached some screenshots that show what you should see from the TAC.

 

The first three attachments are what you should see when you log into TAC and select Configuration->Settings on the left hand panel.  On the right hand side you will see expandable sections for different configuration groups. The first screenshot shows the Artifact Repository section which refers to the Nexus Server.  The second screenshot shows the Software Update section which refers to a different repository within the same Nexus server.  The last screenshot shows the User Libraries section.

 

All of these refer to the Nexus server via its EC2 internal hostname, e.g. ip-10-0-131-87.us-east-2.compute.internal in the screenshots.  This is correct since the TAC server belongs to an EC2 security group and subnet that can resolve the internal hostname of the Nexus server.

 

On the other hand, when you access Nexus yourself form the browser on your laptop you need to use the external hostname for the Nexus server.

 

In the job_conductor_add_artifact_nexus.jpg screenshot, the Nexus configuration in the previous step is being used to provide listbox from the Snapshots directory.  Since I have not actually published any jobs the list shows empty.  But it should still resolve (as it has in the screenshot) rather than just spin.

 

Hopefully that is a helpful starting point, but it does not resolve the issue of the UserId / Nexus Password not working.  If that is not set correctly neither the internal or external access points will work.  So I suspect this is just a password thing.

Six Stars

Re: TAC - Nexus, Artifacts repository is unreachable

Edward and I worked out that the password I was using had an issue.

I changed ti2ETnxVvrGm! to admin123 and the issue cleared up. Obviously admin123 shouldn't be used in production. We didn't find a clear answer as to what Nexus password needs to include/exclude. 

 

 

Employee

Re: TAC - Nexus, Artifacts repository is unreachable

If this should happen to you, you may want to try rebuilding the stack with a different password for Nexus.  The trick we used in this case was to ssh onto the Nexus server itself and follow the steps from this link on how to reset the Nexus admin password.

 

You can find the Nexus working directory at this path /var/talend/6.3.1/nexus/sonatype-work/nexus.